Chris J. Lee

Dallas Drupal Developer

You are here

/usr/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find compass (>= 0) amongst

Had encountered this error on Ubuntu 13.04:

/usr/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find compass (>= 0) amongst

This is because ruby is unable to find an existing rubygem dependancy. It is advised that one uses bundler instead to run compass:

bundle exec compass watch 

If you then try to run bundler and run into this error:

Could not find gem 'sass (= 3.2.9) ruby' in the gems available on this machine.

To fix this issue run bundler install as advised: bundle install

© 2017 Chris J. Lee